Unexpected Downtime for Prairielearn

Incident Report for UMD Engineering IT

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 10:33 EDT

Update

The upgrade is complete.
Posted Aug 21, 2025 - 10:33 EDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 21, 2025 - 10:32 EDT

Identified

The upgrade tasks are taking longer than anticipated. Our dev instance took only a few seconds to upgrade, but the additional data in the production database is taking much longer. The server will be back online once the data upgrade tasks have completed.
Posted Aug 21, 2025 - 10:23 EDT
This incident affected: Learning Technologies (PrairieLearn).